This issue is now resolved. If you believe that you are still experiencing issues related to this, please contact our Support team.
Posted Dec 04, 2025 - 17:42 CST
Monitoring
WellSky is continuing to monitor the impact to caregivers' seeing discrepancies with future shifts on their mobile app. WellSky is working towards a full resolution.
We will continue to monitor closely over the next few days for any influx of cases. If you are still experiencing the issue, please reach out to support.
Posted Dec 02, 2025 - 15:17 CST
Update
WellSky is investigating an issue causing caregivers' to see discrepancies with future shifts on their mobile app. We will continue to update the status page accordingly as we work towards a resolution.
Next Update - by 4 PM CT
Posted Dec 02, 2025 - 13:55 CST
Update
WellSky is investigating an issue causing caregivers' to see discrepancies with future shifts on their mobile app. We will continue to update the status page accordingly as we work towards a resolution.
Next Update - within 1 hour
Posted Dec 02, 2025 - 12:46 CST
Update
WellSky is investigating an issue causing caregivers' to see discrepancies with future shifts on their mobile app. We will continue to update the status page accordingly as we work towards a resolution.
Next Update - within 45 minutes
Posted Dec 02, 2025 - 12:07 CST
Investigating
WellSky is investigating an issue that may impact some clients. For further details and updates, including the final resolution, please visit our status page at https://status.home.wellsky.com. Thank you for your patience while we work to determine the scope and impact of this issue, and to restore full functionality.
Next Update - Posted to the Status Page within 30 minutes
Posted Dec 02, 2025 - 12:01 CST
This incident affected: WellSky Personal Care - US.