WellSky has resolved the issue surrounding caregivers not being able to clock out of the mobile app. If you continue to have any issues please reach out to Personal Care Support for assistance.
Posted Sep 22, 2025 - 17:07 CDT
Identified
WellSky has identified the issue causing some users to be unable to clock out via the mobile application. Until this issue is resolved, users should delete the application and reinstall to bypass the error.
Next Update - 5 PM CT
Posted Sep 22, 2025 - 14:34 CDT
Update
WellSky is investigating an issue causing some users to be unable to clock out via the mobile application.
Next Update - within 30 minutes
Posted Sep 22, 2025 - 13:58 CDT
Update
WellSky is investigating an issue causing users to be unable to clock out via the mobile application.
Next Update - within 30 minutes
Posted Sep 22, 2025 - 13:33 CDT
Investigating
WellSky is investigating an issue that may impact some clients. For further details and updates, including the final resolution, please visit our status page at https://status.home.wellsky.com. Thank you for your patience while we work to determine the scope and impact of this issue, and to restore full functionality.
Next Update - Posted to the Status Page within 30 minutes
Posted Sep 22, 2025 - 13:30 CDT
This incident affected: WellSky Personal Care - US.