Home Health, Hospice, Hospice and Palliative, WellSky DDE, Resource Manager and Payer Maintenance

Scheduled for May 23, 20:00 CDT  -  May 24, 00:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 13:56 CDT

Scheduled

WellSky will perform a scheduled maintenance on Saturday May 23rd, 2026 from 8:00 PM to Sunday May 24th 2026 at 12:00 AM Central Time. During this time, application will be unavailable during maintenance window.

We thank you for your patience as we improve the system.
Posted Apr 30, 2026 - 16:14 CDT
This scheduled maintenance affects: WellSky PayerLink, WellSky Home Health, WellSky Hospice, WellSky Hospice & Palliative, and WellSky Resource Manager.