Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 18, 2026 - 20:00 CDT
Scheduled
WellSky has identified an issue requiring immediate maintenance. We will perform this maintenance on Tuesday August 18th, 2026 from 8 PM to 10 PM (Central Time). During the maintenance window, users may experience temporary unavailability of analytics dashboards, scheduled reports, PDF exports, and related reporting functionality.
We apologize for the inconvenience as we work to provide a better experience for our clients.
Posted Aug 12, 2026 - 15:57 CDT
This scheduled maintenance affected: WellSky Personal Care - US.